eyes

всё-таки с совершенно не умею в CentOS

Пробовал сегодня поднять сервер на CentOS. Задачки-то были, в общем-то несложные.
Но убил на них кучу времени, при это три четверти времени ушло на борьбу с пакетным менеджером, который всё-таки сильно отличается от используемого в Debian/Ubuntu.

Окончательно меня добило вот это:
говно этот ваш CentOS

Мораль проста. Уметь работать надо с любым дистрибутивом, но для комфортной и производительной работы нужен привычный.
eyes

(no subject)

Помните фильму "Маска"?
Эпизод, где Маска приходит в клуб, преображает музыкантов и танцует с Кэмерон Диаз?
СЯУ, что они не просто случайно выбранную музыку играли, а вполне конкретную "Hey, Pachuco". А именно её, потому что чуваков в таких костюмчиках именно пачуко и называли.

Прикольно. Вот тут подробности: http://pikabu.ru/story/kostyum_maski_5117570
eyes

Дурное воспитание

Написал на пикабу историю о том, как неумеренная родительская любовь натурально калечит детей.
Получил в камментах массу отзывов о тех, кого это коснулось (некоторые натурально ошеломили).

И заодно вот такой комментарий:


Это какой-то ад, по-моему.
Tags:
eyes

Позвони мне, Asterisk

Сегодня спросили, можно ли научить asterisk звонить на определённый номер и зачитывать определённое сообщение.
Чтение документации выявило, что не просто можно, а очень даже просто.

Достаточно взять и написать файлик со следующим содержанием:

Channel: SIP/123
CallerID: "Робот Бендер" <000>
Application: Playback
Data: ru/demo-congrats

а затем просто скопировать этот файлик в /var/spool/asterisk/outgoing/

Всё, asterisk немедленно начинает звонить (и удаляет файлик после дозвона).

Теперь построчно разберём, что же там написано:
Channel: SIP/123. куда звоним. В данном случае — на внутренний номер. Можно звонить и наружу, в моём случае это будет выглядеть так: Channel: SIP/mtt_out/79241122333.

CallerID: "Робот Бендер" <000>. От кого звоним. Работает по SIP-каналу, не работает через операторов.

Application: Playback. Играй, музыкант.

Data: ru/demo-congrats. Проиграть файл /var/lib/asterisk/sounds/ru/demo-congrats.wav (или другого подходящего формата, можно выложить в нескольких форматах, чтобы не озадачивать asterisk транскодированием).

Т.е., прикрутить оповещение к системе мониторинга или вообще к любому скрипту получается не просто, а очень просто.
Просто добавь воды скопируй файл.
Tags:
eyes

Парад здорового человека

Слушайте, это же прекрасно. Там пронесли аэростат. Аэростат, Карл!
А ещё прошла колонна исторической техники из которой я на ходу видел только т-34-85, а из оставшегося половину видел только на постаментах, половину только на картинках, а пару-тройку железяк вообще не опознал.

eyes

Блокируем https-сайты на mikrotik

Почему-то в интернете исключительно старые инструкции, предлагающие использовать либо L7-фильтры (нагружает процессор и не работает на https-сайтах), либо писать какие-то адские скрипты.

С августа 2016 года (когда вышла прошивка, посволяющая использовать url в address list-ах), всё стало проще.
Показываю на примере YouTube.
Предположим нам надо заблокировать его.

Всё просто:
/ip firewall address-list
add address="youtube.com" list="youtube" disabled=no 
add address="googlevideo.com" list="youtube" disabled=no

/ip firewall filter
add action=drop chain=forward comment="block YouTube" dst-address-list=youtube disabled=no

[Ну, или в картинках:]Mikrotik Address List
Mikrotik Address List
Mikrotik Filter Youtube
Mikrotik Filter Youtube
Mikrotik Filter Youtube
Tags: